/ home / Bugs / general bug with profanity filter on forums /

General Bug with profanity filter on forums

11:08 pm, May 12, 2016 737 202 1.0 @ 200 wpmrate up Nantuko source
11
While posting today, I discovered that the profanity filters the prefix "h o m o" even though many words using this prefix are in no way derogatory or vulgar.

For example, ♥♥♥♥geneous, ♥♥♥♥geneity, ♥♥♥♥ sapien, ♥♥♥♥morphism, ♥♥♥♥normative, ♥♥♥♥cyclic, ♥♥♥♥nym, ♥♥♥♥phones, ♥♥♥♥phily, ♥♥♥♥allele, etc. There are many other examples.

I'm hoping that this is a bug and is not intended. I understand that a small subset of these words can be used in an inappropriate manner, and thus should be caught by the profanity filter. However, to completely eliminate a prefix of the English language, which generally means same (from the Greek origin) or man (from the Latin origin), is absurd. If this is intended, it isn't even a case of being overly politically correct. Rather, it just seems like poor programming or poor foresight.

Can someone from SuperCell please fix this and/or explain the thought process behind not allowing us to use these words?
forum.supercell.net
11:08 pm, May 12, 2016 737 202 source

Comments

It also filters SBA without reason
Guest @ 3:08 pm, June 12, 2017

Chat

Site Rules

  1. Please be respectful.
  2. Only content directly related to Clash Royale belongs here.
  3. No image macros or memes.
  4. Comments + Content that don't contribute to the discussion or are abusive may be removed.
  5. No sexist, racist or homophobic language.
  6. Posting NSFW material is not allowed.

Links

Latest